horamibibi avatar image
horamibibi asked Spirent_Admin edited

Global topology not automatically referred?

Hello, I'm using the topology tool to implement and port the testing over different testbeds (all derived from the same conceptual topology).

To select the topology to be used by a set of test I'd like to rely on this mechanism (more efficient IMO for porting and code maintenance:

- Leave undefined the Local topology inside the individual test cases (i.e. corresponding field in the General tab is left blank)

- Define the appropriate .tbml file as Global topology

- If I want to switch to the second testbed reusing the same test cases, define a different .tbml file as Global topology


What happens is that, as soon as I leave blank the "Local topology" field of the test cases, I get an annoying red "X" on all the test cases.

It's true, I can specify at run time which topology file to use (Global vs. Local) or I can act at General Preferences level to say "Always use Global topology" (but does this setting prevent me using local topologies on selected test cases?). But it's annoying - and for the less expert user even misleading - having a test case and test case steps marked as "errored" just because a reference, that could be solved "statically" thanks to the Global Topology definition, is only solved at runtime.


What I would expect is something similar to what happens with the Parameter files: as soon as I declare a parameter file as Global, all its contents is automatically available also to the test case editor and to the test case code so to solve the references. Same should happen also with the Global Topology (and I dare say, as default behaviour: if a Global Topology is defined and no Local topology is defined, then the Global topology definitions shall be automatically taken, without waiting for the runtime choice).


Additionally: when a topology is defined (either Global or Local), it would be useful to have a guided support in the "Insert..." menu of the test case editor, as it happens with e.g. Insert Parameter (I'm using iTest 4.1.1 with Enterprise license and this is not available).


This could be a feature request - but in the meanwhile, how to get rid of that annoying (and IMO not really useful) red cross?

10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

lakshminarayana avatar image
lakshminarayana answered Spirent_Admin edited
The one way to overcome this 'x" error in the test case editor is by defining the default session for the procedure in procedure properties and store the device description information as parameter/variable thereby substituting this parameter in the open step. ![alt text][1] [1]: /storage/attachments/3374-testbed.jpg

testbed.jpg (97.4 KiB)
10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.