question

sujichan avatar image
sujichan asked ericnute edited

Error with IxNetwork on iTest

Hi

 

I am getting the following error when starting ixnetwork on itest.

 

Fanfare Ixia IxNetwork command interpreter. Copyright (c) 2005 - 2009, The Fanfare Group, Inc.


Using external tcl interpreter
tcl version: 8.4.7
tclsh location: C:/Program Files/Ixia/IxNetwork/5.40-EA-SP1-Patch1/tcl8.4/bin/tclsh84.exe
tcl library: C:/Program Files/Ixia/IxNetwork/5.40-EA-SP1-Patch1/tcl8.4/lib/tcl8.4
tcl package search path: {C:/Program Files/Ixia/IxNetwork/5.40-EA-SP1-Patch1/tcl8.4/lib/tcl8.4} {C:/Program Files/Ixia/IxNetwork/5.40-EA-SP1-Patch1/tcl8.4/lib}


Loading Tcl package IxTclNetwork... error
    iTest cannot detect the location of IxNetwork. Make sure it is installed correctly.
    can't find package IxTclNetwork


Disconnected...


Press the ENTER key to start a new session in this window...

 

can someone please help me with this?

 

thank you

sujit.

iTesttraffic generationixNetwork
10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

·
koelze avatar image
koelze answered koelze posted

Can you paste the contents of your PATH and TCLLIBPATH environment variables?  I'm assuming that IxNetwork's installed on your machine, which means the most likely caues of the error message is those variables not being set properly, so that iTest can't pick up on their location.

13 comments
10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

sujichan avatar image sujichan commented ·

Hi kevin

 

Yes i have ixnetwork and ixnettcl also installed. I have the ixnet tcl running on the machine. I dont have variables set and i am attaching a screenshot.

 

thank you

sujit.

0 Likes 0 ·
koelze avatar image koelze sujichan commented ·

Can you go to a console and type export (I'm assuming you're on Linux; if you're on windows type set) and show me what is in the PATH and TCLLIBPATH variables there?  For reference, mine looks something like:

 

TCLLIBPATH="C:/Program Files/Ixia/IxOS/5.60-EA" "C:/Program Files/Ixia/IxNetwork/5.40-EA-SP1/TclScripts/Lib"

 

This variable tells iTest where to look for the IxNetwork Tcl Library, if it's not set, iTest won't be able to pick up on an IxNetwork installation.

0 Likes 0 ·
sujichan avatar image sujichan koelze commented ·

Hi Kevin

 

I am using iTest on windows. I have tried to set TCLLIBPATH as you mentioned, but still i get the following error

 

Fanfare Ixia IxNetwork command interpreter. Copyright (c) 2005 - 2009, The Fanfare Group, Inc.


Using external tcl interpreter
tcl version: 8.4.14
tclsh location: C:/Program Files/Ixia/Tcl/8.4.14.0/bin/tclsh.exe
tcl library: C:/Program Files/Ixia/Tcl/8.4.14.0/lib/tcl8.4
tcl package search path: {C:/Program Files/Ixia/Tcl/8.4.14.0/lib/tcl8.4} {C:/Program Files/Ixia/Tcl/8.4.14.0/lib} {C:/Program Files/Ixia/IxNetwork/5.40-EA-SP1-Patch1/tcl8.4/bin}


Running initialization script...
% "C:\Program Files\Ixia\IxOS\5.60-EA-SP1" "C:\Program Files\Ixia\IxNetwork\5.40-EA-SP1-Patch1\TclScripts\Lib"
invalid command name "C:Program FilesIxiaIxOS.60-EA-SP1"

Loading Tcl package IxTclNetwork... error
    iTest cannot detect the location of IxNetwork. Make sure it is installed correctly.
    can't find package IxTclNetwork


Disconnected...


Press the ENTER key to start a new session in this window...

0 Likes 0 ·
koelze avatar image koelze sujichan commented ·

It looks like you just tried to put that in your initialization script as opposed to actually setting the path.  Let's start from the beginning, since it seems like we're not communicating well:

 

Go to Start -> Run, and type cmd.  Once your command prompt is open, type "set".  It will print a long list of variables and values.  Tell me what it prints for PATH and TCLLIBPATH.

0 Likes 0 ·
sujichan avatar image sujichan koelze commented ·

I dont see any TCLLIBPATH set, sorry for the confusion

 

C:\Documents and Settings\systest>set
ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\systest\Application Data
CLIENTNAME=sujichan-mac
ClusterLog=C:\WINDOWS\Cluster\cluster.log
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=SYSSCALE-PC2
ComSpec=C:\WINDOWS\system32\cmd.exe
DEFLOGDIR=C:\Documents and Settings\All Users\Application Data\McAfee\DesktopPro
tection
EICDDrive=D:\
FP_NO_HOST_CHECK=NO
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\systest
ITEST_HOME=C:\Program Files\Fanfare\iTest 3.4\
LOGONSERVER=\\SYSSCALE-PC2
NUMBER_OF_PROCESSORS=4
OS=Windows_NT
Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\In
tel\DMIX;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\I
xia\Tcl\8.4.14.0\bin;C:\Program Files\Fanfare\iTest 3.4;C:\Program Files\Fanfare
\iTest 3.4\iTestRT
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 37 Stepping 2, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=2502
ProgramFiles=C:\Program Files
PROMPT=$P$G
SESSIONNAME=RDP-Tcp#40
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\DOCUME~1\systest\LOCALS~1\Temp\3
TMP=C:\DOCUME~1\systest\LOCALS~1\Temp\3
USERDOMAIN=SYSSCALE-PC2
USERNAME=systest
USERPROFILE=C:\Documents and Settings\systest
VSEDEFLOGDIR=C:\Documents and Settings\All Users\Application Data\McAfee\Desktop
Protection
windir=C:\WINDOWS

C:\Documents and Settings\systest>

0 Likes 0 ·
koelze avatar image koelze sujichan commented ·
Okay, you'll need to set the TCLLIBPATH for us to be able to find the IxNetwork install. In your environment variables (Ctrl Panel -> System, Advanced Tab, Environment Variables). In System Variables, Click "New.." and create a variable named TCLLIBPATH, in it, you want to put your path to the tcl library in IxNetwork. Mine was: "C:/Program Files/Ixia/IxNetwork/5.40-EA-SP1/TclScripts/Lib" (note, it needs to be all forward slashes and in quotes). You should look on your system to see where IxNetwork is installed and find the folder that contains the IxNetwork tcl package. If you installed in a default location, it should be very very similar to where mine is (although maybe slightly differently than the version number). After you've set that, the session should work. You =may= also need to put the IxOs installation in your Path, but I don't think so, and I'm away from my computer that has everything installed so it's difficult to check for sure.
0 Likes 0 ·
vhosakot avatar image vhosakot koelze commented ·

I have the following two environment variables set:

 

PATH = C:\Program Files (x86)\Ixia\IxNetwork\5.50-EA-SP1

TCLLIBPATH = C:\Program Files (x86)\Ixia\IxNetwork\5.50-EA-SP1\TclScripts\Lib

 

I am still getting the following error:

 

Fanfare Ixia IxNetwork command interpreter. Copyright (c) 2005 - 2010, The Fanfare Group, Inc.


Using external tcl interpreter
tcl version: 8.4.14
tclsh location: C:/Program Files (x86)/Ixia/Tcl/8.4.14.0/bin/tclsh.exe
tcl library: C:/Program Files (x86)/Ixia/Tcl/8.4.14.0/lib/tcl8.4
tcl package search path: {C:/Program Files (x86)/Ixia/Tcl/8.4.14.0/lib/tcl8.4} {C:/Program Files (x86)/Ixia/Tcl/8.4.14.0/lib}


Loading Tcl package IxTclNetwork... error
    iTest cannot detect the location of IxNetwork. Make sure it is installed correctly.
    can't find package IxTclNetwork
Initialization Failed:iTest cannot detect the location of IxNetwork. Make sure it is installed correctly.


Disconnected...

 

Please let me know what is wrong. Are my environment variables correct? I did not fine the directory "IxOS" anywhere. I'm using Windows 7. Thanks a lot.

 

Regards,

Vikram Hosakote

0 Likes 0 ·
HosoonK avatar image HosoonK vhosakot commented ·

Loading Tcl package IxTclNetwork... error
    iTest cannot detect the location of IxNetwork. Make sure it is installed correctly.
    can't find package IxTclNetwork

 

This tells that your Windows 7 still does not have proper setting for IxTCLNetwork tcl package.

Please make sure there is no typo in the TCLLIBPATH and you are using forward slash "/" for separator and use space in between with other TCLLIBPATH variables.

 

Once you fix this i am positive it will work even though this (5.50-EA-SP1) is not officially tested version.

We have tested IxNetwork on Windows 7 with IxNetwork 5.40 GA.

 

Thanks,

 

 

0 Likes 0 ·
PadmajaG avatar image PadmajaG HosoonK commented ·

The Tcllib path should be the follows.

TCLLIBPATH = "C:\Program Files (x86)\Ixia\IxNetwork\5.50-EA-SP1\TclScripts\Lib\IxTclNetwork"

 

I saw that you missed the "IxTclNetwork" at the end

 

and also make sure that the whole path is in double quotes.

0 Likes 0 ·
koelze avatar image koelze PadmajaG commented ·

Can you look in your IxNetwork install and see if you can find the IxTclNetwork.tcl?  It's likely to be in the spot that Padmaja suggested, but I wanted to be sure that it's actually there and not somewhere else (the location where it installs changed from 5.30 to 5.40; it may have changed from 5.40 to 5.50 as well, which would explain why that path doesn't work).

0 Likes 0 ·
vhosakot avatar image vhosakot koelze commented ·

Thanks for all the replies guy. Finally, it is working. Here are my environment variables:

 

TCLLIBPATH = "C:/Program Files (x86)/Ixia/IxNetwork/5.50-EA-SP1/TclScripts/Lib/IxTclNetwork" (was missing the forward slashes :smileyhappy: )
PATH = C:\Program Files (x86)\Ixia\Tcl\8.4.14.0\bin

 

Now, the session is starting fine. Thanks a lot experts.

 

Warm Regards,

Vikram Hosakote

0 Likes 0 ·
hpatanka avatar image hpatanka vhosakot commented ·

Hi,

 

I don't know if this is the right place to post this but I am having same problems with IxLoad..

I've set the environment variable as

 

PATH: C:\Program Files (x86)\Ixia\IxLoad\5.10-GA

TCLLIBPATH: "C:/Program Files (x86)/Ixia/IxLoad/5.10-GA/TclScripts/lib/IxLoad"

 

But I am still getting the error



Loading TCL package 'IxLoad'...error
    can't find package IxLoad
Possible resolution:
    iTest cannot detect the location of IxLoad. Make sure it is installed correctly.
Initialization Failed:can't find package IxLoad


Disconnected...

 

Anyone have any ideas?? Btw I'm using iTest 4.1 and IxLoad 5.10

Thanks in advance

0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.