question

arodriguez avatar image
arodriguez asked arodriguez posted

How do you turn on echos inside iTest for Digital Lightwave -Telnet -SCPI?

Hi everyone,

 

I have a testcase I need ot build and the issue is that it is a Digital Lightwave and we must run it through Telnet but when we run it through Telnet we cannot seem to receive any echo back in order to build the testcase. I have to issue commands blindly in order for the session to run and then nothing shows up because there seems to be a loss of echo. This is a test that we have had to SCPI into.

 

Any suggestions?

 

Thanks,

Angel

iTest
10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

arodriguez avatar image
arodriguez answered arodriguez posted

Aha!! I did not see that one-That did it, thanks a lot!

10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

arodriguez avatar image
arodriguez answered arodriguez posted
After I enter the question"SCPI?" then "Enter" then both a second time I receive a "yes" and I enter the next set of "SOUR:FRM:CBIT" but it does not respond in the window nor do I know if it received the response except that I go to the physical machine and see if the test has or has not run. Does this help?

10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

arodriguez avatar image
arodriguez answered arodriguez posted

This is the only one under the nodes other than the previous one that show anything about echoes but it is writing the echoes here. My other sessions work fine.


Session Props.JPG (49.7 KiB)
1 comment
10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

KumarS avatar image KumarS commented ·
click on "terminal" node and you will see the local echo check box.
0 Likes 0 ·
arodriguez avatar image
arodriguez answered arodriguez posted

in session properties, you would uncheck mask echos, remove echos or am I in the wrong window?

 

 


Session Props.JPG (34.4 KiB)
1 comment
10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

KumarS avatar image KumarS commented ·
the local echo setting is under "terminal properties" node. It is under one of the subnodes under there or under the terminal properties node.
0 Likes 0 ·
KumarS avatar image
KumarS answered KumarS posted
It seems like your device does not echo back. You can verify this by using any other telnet client. Itest has a solution for this. You can turn on local echo in the telnet session properties.
10 |950

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.